bobptz
bobptz asked
Member (-1 upvotes)

Google reports Q&A error on wrong version of my page

Hello


Google Search Console keeps reporting Q&A errors (missing field MainEntity) for many pages (like this:  https://learn-greek-online.com/ask-greek/919/what-difference-between-when-another-they-have-same-meaning  ).




However when I go to test it myself at the Google Structured data testing tool, the page passes the test:




What I have noticed is the the page reported to be wrong, has different source.  It has a statement about "viewport".  The one I am examining has no such statement.  So could it be that google keeps examining an old version of the page?  Although I instruct google to test the LIVE page.


How can this be?




Avatar for member Chedders
Chedders
Moderator (202 upvotes)

Your suspicion appears to be correct.

Google is looking at a older version of the page. 

https://webcache.googleusercontent.com/search?q=cache:kDU5NXYmdkwJ:https://learn-greek-online.com/ask-greek/919/what-difference-between-when-another-they-have-same-meaning+&cd=1&hl=en&ct=clnk&gl=uk

As you can see the page was cached on 25 Sep 2019 02:08:46 GMT and if you look at the source there is no mainEntiy. The current live version though that entry is there.

I would assume you have recently updated this page and it can take a while to get reindexed. You can speed things up a little by submitting the page for indexing within search console but if your wanting a lot of pages to be done then its a bit of a waiting game I am afraid. 

Good advice?
3
0
Comments 0
login to reply
Hi I have recently updated the THEME of the forum. However this was a couple of days before google had cached this age. Google Search console seems to have its own cached pages, and insists on using those for "LIVE" test, while the google online tools do pull the live page. This must be a google bug.
Some of these reports do have inaccurate results - there are often cases where you get an error and then it goes away. A test would be if Google is using the data to display a rich snippet. If it is, then I wouldn't worry about it.
Google Search Console gave again the same error, on pages that it says where crawled just yesterday, Sept 28th. Google keeps crawling the wrong version of the page. This must be a Google bug.
Avatar for member Chedders
Chedders
Moderator (202 upvotes)

The main issue here is your expecting everything to be in sync. Google has huge systems which do not have direct access to each other. Search console is well known for being quite out of date to what is shown in search. 

When I make changes to a page / site. I normally give every 6 weeks to settle down before getting to excited. This includes SEO changes I make to see if the changes have had a positive or negative effect. 

Good advice?
2
0
Comments 0
login to reply
Thank you. I gave it 2-3 days and I thought it would be enough.
I THINK I found where the problem was. There was no error on the DESKTOP version of the site. But I noticed google was reporting that it scanned the MOBILE pages and there it found the error. I am using different themes for mobile/desktop. Unfortunately I do not know how to test the mobile version for Q&A errors. Anyway, I updated the mobile theme, and I hope the problem will be solved now.
Copyright ©2020 SEOChat. All Rights Reserved.