Harjinder
Harjinder asked
Member (0 upvotes)
over a year ago

Why my website is not showing on Google?

One of my website is not showing on google here is the link https://nucleon-security.com



*All the on page is done



  • No (no index file is present in the website)

  • robots.txt is done

  • sitemap is done


still website is not showing on google.

#seo#indexing#caching#google
Avatar for member tstolber
tstolber
Moderator (98 upvotes)
over a year ago

I see the site is on Bing and Yahoo - so that would start to make me think penalty.

Once you have the URLs submitted in Google Search Console it will tell you what your coverage is and what the errors are.

Let us know what you are seeing there. 

It is unusual for Google not to have something in its index that is in Bing and Yahoo so I think you may have triggered a penalty - but the coverage report will tell you why you are not getting submitted URLs indexed.

Good advice?
3
0
Comments 0
login to reply
Harjinder Member
over a year ago
Thanks for your reply. Yes!! website is present on yahoo and bing as well. coverage report showing no error and 11 valid urls and 44 excluded urls.
tstolber Moderator
over a year ago
Hi Harjinder - I am willing to take a look at this for you. message me at info at stolber dot com.
Harjinder Member
over a year ago
Kindly check your mail.
Avatar for member Matt1966
Matt1966
Moderator (244 upvotes)
over a year ago

If you haven't already, submit your website to webmaster tools.

Secondly, have you checked if your website has any manual penalties?

That looks like link building to me. Link building always carries a risk of a penalty.



Another thing I found, which I don't think will be the reason... but a major quality signal...
You have a tiny website, yet half the pages you link to internally redirect, I'd sort that pronto.

 

Good advice?
1
0
Comments 0
login to reply
Harjinder Member
over a year ago
Hi Matt Thanks for the reply. I have submitted the website to webmaster tool and there is no manual penalties and no security issue is detected. Everything is fine.
Matt1966 Moderator
over a year ago
How long ago did you submit the site?
Matt1966 Moderator
over a year ago
How long ago did you submit the site?
Harjinder Member
over a year ago
I have submitted the site on webmaster around 2 month ago.
Avatar for member Matt1966
Matt1966
Moderator (244 upvotes)
over a year ago

If you haven't already, submit your website to webmaster tools.

Secondly, have you checked if your website has any manual penalties?

That looks like link building to me. Link building always carries a risk of a penalty.



Another thing I found, which I don't think will be the reason... but a major quality signal...
You have a tiny website, yet half the pages you link to internally redirect, I'd sort that pronto.

 

Good advice?
0
0
Comments 0
login to reply
Avatar for member KnowOneSpecial
KnowOneSpecial
Moderator (68 upvotes)
over a year ago

You have a few technical issues with your site.......

Your site can be address by http and https.  You have some coding done incorrectly is my guess.

Secondly your site takes almost 8 seconds to load.  Go to GTmetrix.com and test your site for the specific issues you need to address to reduce your loading time.

Good advice?
1
0
Comments 0
login to reply
Harjinder Member
over a year ago
My website have a canonical tag and http is redirected to https as well. So i don't thing this an issue. I have seen a lot of sites having very low speed but google cache them.
Avatar for member KnowOneSpecial
KnowOneSpecial
Moderator (68 upvotes)
over a year ago

Quoting:

My website have a canonical tag and http is redirected to https as well. So i don't thing this an issue. I have seen a lot of sites having very low speed but google cache them.

https://i.gyazo.com/dcf63fe91b890e6d6fbf8b49e6c0428e.png

Good advice?
0
1
Comments 0
login to reply
Copyright ©2021 SEOChat. All Rights Reserved.